
 

Retail Mobile Suite 
Product Manual 

 
v2.0 Rev D 

FoundryLogic LLC 
4760 S Highland Dr, #528 
Salt Lake City, UT 84117 
 
http://foundrylogic.com 

http://foundrylogic.com/


 

FoundryLogic LLC Copyright © 2008-2010. All Rights Reserved. 

2 

Retail Mobile Suite – Product Manual v2.0 Rev C 

About This Manual 
This document is the Retail Mobile Suite product manual and contains 
information for software: 

 Installation 

 Configuration 

 Usage 

 Troubleshooting 

 

If you have questions, comments, or wish to report errors in this manual or in the 
software, please contact us at support@foundrylogic.com. 

The software described herein is furnished under a license agreement. 

FoundryLogic LLC 
4760 S Highland Dr, #528 
Salt Lake City, UT 84117 

 
http://foundrylogic.com 

Copyright 
FoundryLogic LLC Copyright © 2008-2010.  All rights reserved. 

Trademarks 
Retail Pro, Windows, Windows Mobile, and Windows CE are registered 
trademark(s) and/or registered service mark(s) in the United States and other 
countries.  FoundryLogic, Retail Mobile Suite, and their associated graphical 
representations and logos, are trademarks and/or service marks of FoundryLogic 
LLC.  All rights reserved. 

 

mailto:support@foundrylogic.com
file:///C:/Users/Scott/Desktop/FoundryLogic/RMS/RetailMobileSuite1.3.x/foundrylogic.com
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1 Getting Started 
Retail Mobile Suite enables you to use Windows Mobile and Windows CE 
scanners and printers to perform the following tasks un-tethered from your POS 
workstations: 

 Physical Inventory 

 Receiving 

 Transfer In and Out 

 Line Buster 

 Inventory Check 

2 System Requirements 
This section describes the Retail Mobile Suite system requirements for the 
workstation and mobile devices. 

2.1 Workstation Requirements 
 Windows 7 (32-bit or 64-bit) or Windows XP Service Pack 3 

 Windows Mobile Device Center 6.1 (or later) or ActiveSync 4.5 (or later) 

 1GB Ram 

2.2 Mobile Device Requirements 
 Windows CE 5.0 (or later) or Windows Mobile 5.0 (or later)  

 64MB Ram 

3 Installation and Setup 
Follow the steps below to install and setup Retail Mobile Suite.  Please note that 
all installation steps must be performed by a user with Administrator rights. 

3.1 Install ActiveSync or Windows Mobile Device 
Center on a Workstation 
ActiveSync (Win XP) or Windows Mobile Device Center (Win 7) is used by Retail 
Mobile Suite on the workstation to communicate with mobile devices that are 
connected to the workstation through a physical docking station or cradle. 

Please also note that ActiveSync or Windows Mobile Device Center software is 
required to install Retail Mobile Suite software on your mobile devices. 
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Microsoft ActiveSync and Windows Mobile Device Center software is available 
for download on the Microsoft website at http://www.microsoft.com.  Install 
ActiveSync or Windows Mobile Device Center on each workstation that you will 
use to dock your mobile devices. 

3.2 Install Retail Mobile Services (Optional) 
If you have a wireless network at your location and you want to connect your 
mobile devices wirelessly to Retail Mobile Suite, then install Retail Mobile 
Services on one (or more) systems in your network.   

Retail Mobile Services acts as a “server” on your network to provide a 
“destination” for both the Desktop Component software and the Mobile Device 
software to send and receive data. 

Double-click the Setup.exe executable in the RetailMobileServices installation 
folder and follow the on-screen instructions to install Retail Mobile Services. 

Windows 7 users must also perform the following steps to enable IIS features: 

1. Go to Control Panel > Programs and Features, and on the left-hand 
side of the window, click Turn Windows features on or off. 

2. Expand the features list to the following location:  Internet Information 
Services > World Wide Web Services > Application Development 
Features 

3. Check the box next to the following features:  .NET Extensibility and 
ASP.NET.  When you check these boxes, some other features will also 
automatically enable themselves.   

4. Click OK. 

The installer creates a new Windows Service called RetailMobileServices and 
sets it to start automatically on workstation startup. 

To start the service after installation is complete, either reboot your system or 
start the service manually using the Services Control Panel:   

1. Go to Start > Control Panel > Administrative Tools > Services 

2. In the Services window, scroll down and right-click RetailMobileServices, 
click Properties, then Start. 

3.3 Install Retail Mobile Suite Desktop on a 
Workstation 
Install the Retail Mobile Suite desktop component on each workstation you will 
use to interface Retail Mobile Suite with Retail Pro.  Be sure to include all the 
workstations where you plan to process mobile transactions such as:  Physical 
Inventory, Receiving Vouchers, Transfers, and Line Buster Sales Receipts. 

http://www.microsoft.com/
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Double-click the Setup.exe executable in the RetailMobileSuite installation folder 
and follow the on-screen instructions. 

3.4 Start and Configure Retail Mobile Suite 
Desktop 
The installer automatically places a shortcut to launch Retail Mobile Suite in your 
Start Menu and Startup folder so that Retail Mobile Suite launches automatically 
on the workstation when you login. 

To launch Retail Mobile Suite, go to Start > Programs > Retail Mobile Suite 
and double-click the Retail Mobile Suite shortcut. 

Once launched, you can access Retail Mobile Suite by either right-clicking or 
double-clicking the Retail Mobile Suite icon in the System Tray. 

 

Right-click the System Tray icon to display the Retail Mobile Suite menu directly: 

 

Double-click the Retail Mobile Suite icon to display the Retail Mobile Suite 
application window: 
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3.5 Stop Retail Mobile Suite Desktop  
If you want to stop the Retail Mobile Suite Desktop Component, you can either 
right-click the System Tray icon and select Exit, or from the application window, 
select File > Exit. 

Please note that just closing the application window does not stop the Retail 
Mobile Desktop Component.  If you close the application window, you will still 
see the Retail Mobile Suite icon in the System Tray. 

3.6 Set Retail Mobile Suite Desktop Options 
Restart the Retail Mobile Suite Desktop Component if you stopped it in the 
previous step. 

To set Retail Mobile Suite Desktop options, right-click on the System Tray icon 
and select Options… or select Tools > Options… from the application window. 

 

Retail Pro Options 

Use the Retail Pro tab to select the Retail Pro version, workstation and 
installation directory. 



 

FoundryLogic LLC Copyright © 2008-2010. All Rights Reserved. 

8 

Retail Mobile Suite – Product Manual v2.0 Rev C 

 

Option Description Default Value 

Retail Pro 
Version 

Indicates which version of Retail Pro 
you wish to use with Retail Mobile 
Suite. 

Version 8 

Workstation 
No. 

Indicates the Retail Pro Workstation to 
use with Retail Mobile Suite 

1 

Installation 
Directory 

The Retail Pro installation directory.  
For Retail Pro Version 9, the 
installation directory is typically: 
C:\RetailPro9 

C:\RetailPro 

Interface 
Directory 

This is the directory used to interface 
with Retail Pro.  This value is set 
automatically based on the Retail Pro 
Version and Installation Directory 
settings above. 

C:\RetailPro\Rpro\Palm 
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Communications Options 

 

Option Name Description Default 
Value 

ActiveSync 
Settings 

The ActiveSync settings only affect mobile 
devices physically connected to the workstation. 

 

Use ActiveSync If checked, Retail Mobile Suite uses ActiveSync 
to communicate with the mobile device. 

Checked 

Force Guest 
Partnerships 

Forces ActiveSync to connect using Guest 
Partnerships only.  This is speeds up 
connections to ActiveSync when you are using 
several devices and don‟t need the features 
included with the ActiveSync‟s Standard 
Partnerships. 

Note: This option requires Administrator 
privileges to take effect. 

Checked 
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Retail Mobile 
Web Service 
Settings 

The Retail Mobile Services settings allow a 
workstation to communicate with any mobile 
device configured with the same host, port and 
channel. 

 

Use Retail 
Mobile 
Services 

If checked, Retail Mobile Suite uses Retail 
Mobile Services to communicate with devices. 

Unchecked 

Host The Retail Mobile Services hostname or IP 
Address. 

 

Port The Retail Mobile Services port number. 6131 

Channel The Retail Mobile Services channel. 

Use this setting to segregate the traffic between 
mobile devices using the same Retail Mobile 
Services host and port. 

Typical settings for this include: PI, Receiving, 
and Line Buster.    

 

3.7 Install Retail Mobile Suite on a Mobile Device 

Connect Your Mobile Device 

Connect your mobile device to the workstation per the manufacturer‟s 
instructions.  Be sure all cables are connected and that the mobile device is 
powered on.  Confirm that ActiveSync or Windows Mobile Device Center is 
successfully connected to the mobile device before proceeding. 

Note for Windows 7 users:  In order to enable non-privileged users to install 
Retail Mobile Suite on a mobile device, you must configure the file 
c:\Windows\WindowsMobile\ceappmgr.exe to Run as Administrator for 
all users by performing the following: 

1. As an Administrator, use File Explorer and right-click on 
c:\Windows\WindowsMobile\ceappmgr.exe. 

2. Select Properties > Compatibility > Change setting for all users 

3. Check Run this program as an Administrator 

4. Click OK twice. 

If you do not perform this step, non-privileged users will receive the following 
error when trying to install Retail Mobile Suite on a mobile device:  
“Application Manager cannot install this application on your mobile device due 
to an invalid setup file.” 
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Install Retail Mobile Suite on the Mobile Device 

With Retail Mobile Suite running on your workstation and with your mobile device 
connected, you are now ready to install Retail Mobile Suite on the mobile device. 

1. Right-click on the Retail Mobile Suite icon in the System Tray and select 
Install on Mobile Device….  This launches an Installation Wizard to lead 
you through the installation process: 

 

2. On the following screen, select the type of device and the software 
components to install.  If you make a mistake or forget a component, click 
Cancel and then restart the Installation Wizard. 

 

Important Notes 

 Please follow the instructions in the Installation Wizard completely. 
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 If something does go wrong, click Cancel and restart the installation 
process. 

 If your mobile device asks “where to install application components,” 
select the default, which is usually called „Device.‟  Installing to other 
locations (such as storage cards) can lead to unpredictable results. 

 Most new mobile devices come pre-installed with .Net CF 2.0 Service 
Pack 2 and SQL CE 3.0 or later.  If these components are already 
installed on your device, you do not need to install them again. 

 If the “Applications Already Installed” message appears for either 
Microsoft .NET CF2.0: 

 

Or Microsoft SQL Mobile 2005: 

 

Then click „No‟ and then click „Cancel‟ in the Add/Remove Programs 
dialog before clicking „Next‟ in the Wizard: 
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3.8 Start Retail Mobile Suite on the Mobile Device 
On the mobile device, start Retail Mobile Suite by going to Start > Programs > 
Retail Mobile Suite.  You will be presented with a Welcome Screen: 
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Touch Trial to proceed in Trial Mode, or if you have purchased a License Key to 
unlock the software, enter the License Key and touch Unlock. 

Trial Mode 

Trial Mode allows you to evaluate the functionality of Retail Mobile Suite.  You 
can scan as many items as you wish, but in Trial Mode, Retail Mobile Suite is 
limited to uploading a maximum of 10 scans per session into Retail Pro. 

Note:  the Retail Mobile Suite Desktop Component has no Trial Mode limitations 
and may be installed on any number of workstations. 

Unlocking your Mobile Device 

To purchase a License Key, contact your Retail Pro reseller or contact 
FoundryLogic (email: info@foundrylogic.com).  For each License Key, you will 
need to provide the unique Device Id displayed on the Welcome screen.  
License Keys are issued specifically for each mobile device.  When you receive 
your License Key, enter it in the field provided and touch Unlock. 

Main Menu 

After you touch Trial or Unlock, the Main Menu is displayed: 

 

3.9 Set Mobile Device Options 
From the Main Menu, click on File > Options to adjust or review important 
settings that control the behavior of Retail Mobile Suite on your mobile device. 
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Settings are divided into the following categories: 

 Inventory 

 Sessions 

 Wedge 

 Server 

 Language 

At the bottom of the screen, select the tab corresponding to the desired category 
to review or adjust those settings.  Be sure to click OK to save your changes. 
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Inventory 

 

Item Lookup Order 

Use the Item Lookup Order dropdown box to set the order in which Retail Mobile 
Suite tries to lookup items. 

Reload Inventory 

Click on Reload Inventory to manually reload an inventory file whose previous 
load was interrupted. 

Clear Inventory 

Click on Clear Inventory to remove the current inventory file from the device. 
(This functionality is provided in the event that the mobile device has insufficient 
memory to process a new inventory without first removing the existing inventory 
file.) 
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Sessions 

 

Auditable 

Check or uncheck the Auditable flag as desired.  This flag controls whether or 
not the order of scans is preserved (auditable) or consolidated.  Consolidated 
scans result in smaller files, but most users prefer to check the auditable flag in 
order to preserve the scan order in the results. 

 

Blind PI 

This setting controls whether or not to display the store‟s on-hand quantity for a 
given item.  Note that store quantities can only be shown if the inventory file has 
been generated with store quantities. 

Show Price With Tax 

When checked, prices are shown with tax, where applicable. 

Max Histories 

This setting is used to determine how many sent or deleted sessions to store on 
the device.  When the limit is reached, the oldest session is permanently purged 
from the device. 

Storage Location 

The Storage Location setting allows you to choose where session data is stored.  
You may choose any top-level directory on your device, including those for 
storage cards, if available. 
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When you change the Storage Location, you will be asked whether or not to copy 
the old session data to the new Storage Location and whether or not to delete 
the old session data from the old Storage Location. 

Wedge 

„Wedge‟, „Wedge Mode‟, „ScanWedge‟ are all terms that describe the mode 
wherein the mobile device‟s scanner sends scanned data to an application as a 
series of key strokes.  Generally, mobile devices with scanners include an 
application, sometimes called „scan wedge‟ or „data wedge‟ to support this 
function.   

Tips for configuring specific hardware to work with Retail Mobile Suite can be 
found at http://foundrylogic.com.  You may need to consult your mobile device 
manufacturer‟s documentation on how to start and configure the scanner 
application to send barcode data followed by the ENTER key. 

After you have configured the hardware, you usually only have to perform a test 
scan of an item using this screen.  Verify that the scan is correct by comparing 
the barcode with the number shown on the screen.  If different, click Reset, 
check your mobile device‟s scan wedge application settings and try again. 

 

Notes: 

 If your scanner has multiple scan buttons, scan once with each button.  Do 
not click Reset between each scan. 

 Some scanners need to be configured to send a prefix character.  If so, 
use a non-alphanumeric character, such as form feed (ASCII 12), if 
possible.  Do not use characters such as tab, enter or carriage return. 

http://foundrylogic.com/
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 If you change your hardware settings, always retrain Retail Mobile Suite 
by clicking Reset and performing a test scan on the Wedge configuration 
screen to ensure that your scanner is correctly configured.  To properly 
train Retail Mobile Suite, make sure to test all the scan buttons on the 
device. 

 When scanning, if the initial scan is correct, but subsequent scans 
appear in the “Count” field, then the scanner is not configured 
correctly! 

Server 

 

Use Retail Mobile Services 

Check this box if you plan to connect your mobile device wirelessly to the Retail 
Mobile Web Service. 

Host 

Enter the hostname or IP address of the Retail Mobile Web Service 

Port 

Enter the port number for the Retail Mobile Web Service.  The default port 
number is 6131. 

Channel 

Enter a Channel name to match the same Channel name you set at the Desktop.  
This feature allows different transaction types to be segregated by channel.  For 
example, Line Buster transactions may be sent to a “Line Buster” channel, which 
then is the same channel to set at your Checkout workstations to process Line 
Buster transactions. 
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Language 

 

Use the language setting to override the regional settings on the device and 
choose a language appropriate for your needs. 

Note:  many languages and dialects displayed may not be specifically supported. 

3.10 Retail Pro Configuration 

Retail Pro V8 

Workstation Preferences 

In order to use Retail Mobile Suite with a Retail Pro V8 workstation, the 
workstation must be configured to work with a portable barcode reader.  In Retail 
Pro, go to Workstation Preferences > Peripherals > Portable Barcode and 
select „Palm‟ from the Barcode Reader Type. 
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Barcode Button 

On Retail Pro screens, use the Menu Designer to add the Barcode button to 
import items into documents: 

 

The Barcode button may be added to any of the following Retail Pro documents: 

1. POS 

a. Receipts 

b. Sales Orders 

i. Customer Order 

ii. Special Order 

iii. Store Registry 

iv. Company Registry 

2. Purchasing 

a. Vouchers 

b. Purchase Orders 
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3. Transfers 

a. Slips 

b. Transfer Orders (add Items Menu, which includes Barcode) 

4. Adjustments 

a. Memos 

Enable Portable Terminal, Smart Scan, and Zones in RproPI 

In Retail Pro‟s PI tool, go to Options > WS Prefs > Options, check Use 
Portable Terminal and click OK: 

 

Next, go to Options > System Prefs > System, select Use Zones, and click 
OK: 

 

Finally, go to Options > System Prefs > SmartScan and set the Mode to 
Basic: and click OK: 

 

Retail Pro V9 

Workstation Preferences 

In order to use Retail Mobile Suite with a Retail Pro V9 workstation, the 
workstation must be configured to work with a portable barcode reader.  Go to 
Workstation Preferences > Peripherals > Inventory Scanner and select „Palm 
SPT1800 v.1.0.0‟ from the list of supported inventory scanners, then click 
Update. 
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Barcode Button 

On Retail Pro screens, use the Menu Designer to add the Upload Items button 
to import items into documents: 

 

The Upload Items button may be added to any of the following Retail Pro 
documents: 

1. Sales 

a. Receipts 

b. Sales Orders 

i. Customer Order 

ii. Special Order 

iii. Store Registry 
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iv. Company Registry 

2. Purchasing 

a. Vouchers 

b. Purchase Orders 

3. Transfers 

a. Slips 

c. Transfer Orders 

4. Merchandise 

a. Adjustments 

Enable Zones 

Go to System Preferences > Local Preferences > Merchandise > PI Tool > 
Options and select Use Zones from the Physical inventory type dropdown 
box: 
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4 Using Retail Mobile Suite 

4.1 Generate an Inventory File 
An inventory file is used to load inventory information on the mobile device.  This 
file is generated from your Retail Pro database. 

To generate the inventory file: 

Right-click on the Retail Mobile Suite System Tray icon and select Generate 
Inventory File: 

 

Login to Retail Pro 

If your security configuration requires it, you may be asked to provide a user 
name and password with which to log into the Retail Pro database: 

 

Configure the Inventory File 

Use the following windows to configure the inventory file: 
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Departments 

Check the box next to each Department, Class or Subclass that you want to 
include in the generated inventory file. 

Click the + or - symbols to expand or collapse each element as desired. 

Note that checking the top-level box named „All‟ checks all Departments, Classes 
and Subclasses.  Similarly, unchecking „All‟ unchecks all Department, Classes 
and Subclasses. 

Also, you may uncheck or check a Department to uncheck or check all of the 
Classes and Subclasses within that Department and uncheck or check a Class to 
uncheck or check all of the Subclasses within that Class. 

Retail Pro V9 users may also choose to display inactive Departments by 
checking the Show inactive Departments setting.  Note that this setting is not 
displayed when using Retail Pro V8. 
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Vendors 

Use the Vendors tab to select items by Vendor for the inventory file (just like 
Departments above). 

 

Retail Pro V9 users may also choose to display inactive Vendors by checking the 
Show inactive Vendors setting.  Note that this setting is not displayed when using 
Retail Pro V8. 

Items 

Use the Items tab to select the following options: 
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Option Description 

Subsidiary Allows you to choose the subsidiary from which inventory is 
queried. 

Store Allows you to choose the store from which inventory is queried. 

Include inactive 
Items 

Check to include inactive items in the inventory file.  (Retail Pro V9 
only) 

Item No Min 
Size 

The minimum size of item numbers printed on labels.  Item 
numbers smaller than this size are left padded with zeros.  Item 
numbers longer than this size are left as-is. 

ALU If checked, each item‟s primary ALU is included in the inventory file. 
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ALU Min Size The minimum size of primary ALUs printed on labels.  Primary 
ALUs smaller than this size are left padded with zeros.  Primary 
ALUs longer than this size are left as-is. 

UPC If checked, each item‟s primary UPC is included in the inventory 
file. 

Vendor ALU If checked, each item‟s alternate vendor ALUs are included in the 
inventory file. 

Vendor ALU 
Min Size 

The minimum size of alternate vendor ALUs printed on labels.  
Alternate ALUs smaller than this size are left padded with zeros.  
Alternate ALUs longer than this size are left as-is. 

Vendor UPC If checked, each item‟s Vendor UPCs are included in the inventory 
file. 

Description 1 If checked, each item‟s Description 1 text is included in the 
inventory file. 

Description 2 If checked, each item‟s Description 2 text is included in the 
inventory file. 

Attribute If checked, each item‟s Attribute text is included in the inventory file. 

Size If checked, each item‟s Size text is included in the inventory file. 

Price Level Identifies the Price Level used to determine item prices in the 
inventory file. 

Cost If checked, each item‟s Cost is included in the inventory file. 

Price/Cost 
Decimals 

Determines the number of decimals to display with prices. 

Store Quantity If checked, each item‟s on-hand store quantity is included in the 
inventory file. 

 

Generate the Inventory File 

Press OK to generate the inventory file after reviewing and making any changes 
to the settings above. 

Update the Inventory File on Mobile Devices using ActiveSync 

When configured to use ActiveSync, Retail Mobile Suite automatically checks the 
inventory file when a mobile device is connected.  If the inventory file on the 
mobile device is older than the desktop‟s inventory file, the file on the mobile 
device is updated. 
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Update the Inventory File on Mobile Devices using Retail Mobile 
Services 

If the mobile device is configured to use Retail Mobile Services, the Desktop 
Component will automatically send the most recent Inventory File to Retail 
Mobile Services. 

Mobile devices configured to use Retail Mobile Services may then update their 
Inventory File by touching Update Inventory on the Main Menu. 

4.2 Manage Sessions 
Retail Mobile Suite‟s Main Menu on the mobile device appears as follows and 
lets you choose a task to perform: 

  

Managing Sessions 

A session is a collection of items and counts that can be managed like a file, 
allowing you to save your progress and switch between tasks.  Selecting any of 
the following tasks from the Main Menu allows you to manage the corresponding 
sessions for that task. 

 Physical Inventory 

 Receiving 

 Transfer In 

 Transfer Out 

 Line Buster 
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Creating a New Session 

Before you can enter transactions, or scan and count items for Physical 
Inventory, you must create a session to organize the transactions. 

Clicking on any of the scan and count tasks on the main menu will display the 
session manager screen for the task: 

 

Create a new session by first entering a name in the text field and then click 
New.  Or, leave the name blank and click New to have Retail Mobile Suite 
generate a uniquely named session for you. 

Opening a Session 

Once a session has been created, it can be opened at any time by selecting the 
session and clicking the Open button or double-click the session. 

Deleting a Session 

To delete a session, select the session and then click Delete on the File Menu. 
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Send a Session 

To Send a session to the Retail Mobile Suite Desktop, select the session and 
click Send.  The next time the mobile device is connected wirelessly to the Retail 
Mobile Web Service, or physically connected with ActiveSync, the session will be 
uploaded to Retail Mobile Suite Desktop and made available for use in Retail 
Pro. 

White, Red, and Green Session Status 

Sessions in progress that have not yet been sent appear in White.  Sessions that 
have successfully been sent to the Desktop appear in Green, and sessions that 
have not yet been received by the Desktop appear in Red as shown below: 
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Editing a Session’s Details 

To edit a session‟s details, select it and click Edit.  This displays the following 
screen where you can edit some of the information about the session: 

 

4.3 Scan Items 
Once you have created a session, press Open (or New) to display a screen for 
the type of transaction where you can begin scanning items.  The following 
screen shot is a picture of the Physical Inventory screen: 
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Scanning Procedure 

To scan an item, aim the barcode scanner at a barcode and press the scan 
button on the mobile device.  If the scanner and Retail Mobile Suite have been 
configured correctly, any information known about the item will immediately 
display upon scanning: 
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Manual Entry 

If a barcode is not readable, you can manually enter the barcode value in the any 
of the 3 identifier fields (Item #, ALU or UPC).  Press ENTER on the device to 
cause Retail Mobile Suite to lookup the item before setting the count. 

Adding Counts 

By default, cursor input focus is directed to the Count field to accept the count of 
items.  Entering a number here and scanning a new item automatically adds the 
new scan to a previous item‟s quantity and looks up the next item.  This enables 
very rapid scanning since there are no extra steps involved. 

After scanning an item, you may also enter a count and push the ENTER key on 
your mobile device to add your count to the item‟s quantity without changing 
focus. 

Setting the Quantity 

To set an item‟s quantity with addition to previous scans, enter the count and 
press the Qty button. 

Deleting a Scan from the Session 

To delete the current scan from the session, use the scroll bar to display the scan 
and then press the Del button. 

Summary Totals 

Retail Mobile Suite keeps 3 summary totals while you are scanning which you 
can view: 

 Scans – The total number of scans in the session 

 Items – The total number of different items in the session 

 Total – The total quantity of all items in the session. 

Items and Total are particularly useful for comparing results with any pre-count 
totals. 

To choose which summary to display, select the combo box just above the Qty 
button and choose the summary total you wish to see: 
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File Menu 

The File menu lets you Save, Rollback and Close your session: 

 

Save 

You may save your progress at any time by either pressing the Save button or by 
clicking File > Save. 
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Rollback 

At any time, you may choose to rollback any changes made to the session since 
the last save.  Simply click File > Rollback.  You will be asked to confirm this 
action.  

Close 

You may close the session by clicking ok at the top right corner of the screen, by 
pressing your mobile device‟s ESC key, or by clicking File > Close. 

If you attempt to close the session without first saving, you will be warned and 
given a chance to save the session before closing it.  Please note that unsaved 
changes are lost. 

Print Menu 

The Print menu lets you print labels for the current item or an entire list.  You can 
also enable Quick Print mode, which prints a label everytime you scan an item.  
See Section 5 Printer Setup for more information on configuring a serial or 
Bluetooth-enabled printer to work with Retail Mobile Suite on your mobile device. 

 

Print… 

Select this menu item to show the Print Label dialog: 
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Steps to print a label: 

 Choose a Print Template. 

 Select Current to print a label for only the currently displayed item or All 
to print labels for each item in the session. 

 Select the number of Copies.  You can choose to print a specific number 
of copies or print the actual Scanned Quantity.  (“Scanned Quantity” is 
very useful in conjunction with All above to print a label for each item in 
the session.) 

 If the Printer Status displays as disconnected, adjust the serial port as 
needed and press Connect. 

 Press OK to print or Cancel to abort the operation. 

Quick Print 

Quick Print mode simplifies printing by automatically printing labels as you scan.  
As above, you can choose to print a fixed number of labels for each scan or print 
labels for the scanned quantity.  Note that in Quick Print mode, you will not be 
able to select printing for All items. 

Turn on Quick Print mode by clicking on the menu item.  The Print Label dialog 
will display as above.  Make your selections and click OK to enable Quick Print 
mode or Cancel to leave it off. 

Turn off Quick Print mode by clicking on the menu item again.  The following 
screen shows Quick Print mode enabled: 
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4.4 Inventory Check 
Use the Inventory Check task from the Main Menu to quickly scan and lookup 
information from the inventory file for an item: 

 

File Menu 

Close 

You can close the session by clicking ok at the top right corner of the screen, 
pressing your mobile device‟s ESC key, or by clicking File > Close. 
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Print Menu 

The Print menu lets you print labels for the current item and also lets you enable 
Quick Print mode, which prints a label everytime you scan.  See Section 5 
Printer Setup for more information on configuring a serial or Bluetooth-enabled 
printer to work with Retail Mobile Suite on your mobile device. 

 

Print… 

Select this menu item to show the Print Label dialog: 

 

Steps to print a label: 
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 Choose a Print Template. 

 When performing Inventory Check, you may only print labels for the 
currently displayed item. 

 Select the number of Copies. 

 If the Printer Status displays as disconnected, adjust the serial port as 
needed and press Connect. 

 Press OK to print or Cancel to abort the operation. 

Quick Print 

Quick Print mode simplifies printing by automatically printing labels as you scan.  
As before, you can choose to print a certain number of labels for each scan, but 
when performing Inventory Check, you will not be able to select Scanned 
Quantity or All. 

Turn on Quick Print mode by clicking on the menu item.  The Print Label dialog 
will display as shown above.  Make your selections and click OK to enable Quick 
Print mode or Cancel to leave it off. 

Turn off Quick Print mode by clicking on the menu item again. 

4.5 Add Counts to a Physical Inventory Zone in 
Retail Pro 

Retail Pro V8 

To download counts collected on your mobile device into a zone in Retail Pro V8: 

1. If needed, generate a new inventory file for your mobile device. 

2. Create a new Physical Inventory session for the zone you want to count. 

Tip: The session name is not imported into Retail Pro, but it is useful to 
give meaningful names to your sessions.  For example, naming the 
session with the same name as its corresponding zone makes it easier to 
remember what activity the session includes.  

3. On the mobile device, Open the session, scan and count the items in the 
zone, then Save and Send the session to Retail Mobile Suite Desktop. 

4. If you are wirelessly connected to the Retail Mobile Web Service, your 
session should send immediately and show a Green status.  If you 
physically dock your device, then connect the device to your workstation.  
(Check that ActiveSync is connected with the device.) 

5. Start Retail Pro‟s PI Tool and create a new zone.  The following screen 
shows what would happen if you created a new zone with the name 
AISL1: 



 

FoundryLogic LLC Copyright © 2008-2010. All Rights Reserved. 

42 

Retail Mobile Suite – Product Manual v2.0 Rev C 

 

6. Click Portable Terminal to download data from Retail Mobile Suite.  This 
causes Retail Mobile Suite to popup a Scan Sessions window: 
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7. If your session is not displayed, check that the session has a Green status 
on the mobile device (indicating the session has been successfully sent) 
and click Refresh. 

8. Highlight the session you wish to download into the zone and click Select. 

Please note that all sessions ready for download are displayed when the 
Scan Sessions window is opened.  Choose the session carefully. 

9. Click Close to review and edit the new Zone: 
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Retail Pro V9 

To download counts collected on your mobile device into a zone in Retail Pro V9: 

1. If needed, generate a new inventory file for your mobile device. 

2. On the mobile device, create a new Physical Inventory session for the 
zone you want to count. 

Tip: The session name is not imported into Retail Pro, but it is useful to 
give sessions meaningful names.  For example, naming the session with 
the same name as its corresponding zone makes it easier to remember 
what activity the session includes.  

3. Open the session, scan and count the items in the zone, then Save and 
Send. 

4. If you are wirelessly connected to the Retail Mobile Web Service, your 
session should send immediately and show a Green status.  If you 
physically dock your device, then connect the device to your workstation 
and check that ActiveSync is connected with the device. 
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5. In Retail Pro, go to Merchandise > Inventory > Physical Inventory > 
Zones and create a new Zone.  The following screen shows what would 
happen if you created a new Zone with the name AISL1: 

 

10. Push the Scanned button and then Add Counts to bring up Add Counts 
dialog: 
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11. Make sure you have connected your mobile device and then click 
Portable Device, which will then allow you to choose a scan session for 
import: 
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12. Select the session you wish to download into the zone. 

Please note that all sessions ready for download are displayed when the 
Scan Sessions window is opened.  Choose the session carefully. 

Also note that if too much time is taken to select a session, Retail Pro V9 
may timeout.  If this happens, repeat the procedure. 

13. Click OK and then Close to review and edit the counts: 
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4.6 Import Counts into a Transfer, Voucher, or 
Sales Receipt 
To download counts into Retail Pro documents, make sure you have added the 
Barcode (V8) or Upload Items (V9) button to the document form and follow the 
steps below: 

Retail Pro V8 and V9 

1. Connect your mobile device to the workstation and send the document 
sessions you wish to download into Retail Pro. 

2. Create a document in Retail Pro as normal and click the Barcode or 
Upload Items button when ready. 

3. Select the desired session from the Scan Sessions popup. 

4.7 Line Buster 
Use Line Buster to speed-up checkout by pre-scanning a Customers‟ shopping 
basket. 
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Preparation 

1. Before line busting, you must obtain a set of “tickets” that will be 
exchanged between Customers and Cashiers.  Each ticket should also 
have a barcode that is unique such that two different Customers could 
never present the same barcode to two different Cashiers at the same 
time.  Any simple sequence of barcode values is sufficient provided there 
are no duplicates. 

2. To perform line busting, you must use Retail Mobile Services and a 
wireless network to connect your mobile devices. 

3. On the mobile devices and Retail Pro POS workstations that will be used 
for line busting, configure the Server & Communication Options for Retail 
Mobile Services to use the same Channel name (such as “Line Buster”): 

Mobile Server Settings 

 

Desktop Communications Settings 
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Procedure 

1. A Sales Associate clicks the Line Buster button in the main menu of Retail 
Mobile Suite on the mobile device.  The Line Buster session manager is 
displayed. 

 

2. The Sales Associate takes out a ticket, scans it, and then hands the ticket 
to a Customer waiting in line.  A Line Buster session for the ticket is 
displayed on the mobile device: 



 

FoundryLogic LLC Copyright © 2008-2010. All Rights Reserved. 

51 

Retail Mobile Suite – Product Manual v2.0 Rev C 

 

3. The Sales Associate then scans each of the items in the Customer‟s 
basket. 

 

4. When finished, the Sales Associate presses Checkout and then repeats 
the process with the next customer.  Retail Mobile Suite will automatically 
save and send the session to the Desktop (wirelessly through Retail 
Mobile Services). 

5. The Customer proceeds to the Cashier and presents a Line Buster ticket. 
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6. In Retail Pro, the Cashier creates a new Receipt and then presses either 
the Barcode (V8) or Upload Items (V9) button to pop-up the Scan 
Sessions window: 

 

7. The Cashier scans the barcode on the ticket.  The Line Buster session 
corresponding to the ticket is automatically selected and imported into the 
Receipt.  The Cashier then completes the sale as normal. 

5 Printer Setup 

5.1 Connecting a Mobile Printer 
Please consult your mobile printer manufacturer‟s instructions.  What follows 
here are general directions for connecting a Bluetooth mobile printer to your 
mobile device: 

1. Turn on your mobile printer. 

2. Go to Start > Settings > Bluetooth > Devices: 
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3. Click Add new device…  Windows Mobile will search for nearby devices. 

4. Select your mobile printer and click Next: 

 

5. Enter the passcode and click Next, if requested: 
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6.  Select Serial Port and click Finish: 

 

7. Select COM Ports: 
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8. Select New Outgoing Port, then select your device and click Next: 

 

9. Select COM7 and click Finish: 
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10. When completed, your Bluetooth settings screen should look like: 

 

5.2 Testing the Connection 
To test the connection to your printer, simply follow these directions: 

1. Launch Retail Mobile Suite on the mobile device. 

2. Click on Inventory Check. 

3. Click Print > Print… 

4. Set the COM port to COM7 and click Connect. 
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5. Check the printer status displayed: 

 

5.3 Creating Print Templates 
Retail Mobile Suite uses simple text file-based templates for printing labels.  Here 
is an example template: 

! 0 200 200 280 1 

LABEL 

CONTRAST 0 

TONE 0 

SPEED 5 

PAGE-WIDTH 380 

BAR-SENSE 

;// PAGE 0000000003800240 

CENTER 

T 4 0 0 9 Retail Mobile Suite 

T 7 0 0 54 http://foundrylogic.com 

T 7 0 0 78 +1 (858) 243-1822 

T 7 0 0 123 $DESC2 

BT 7 0 5 

B EAN13 2 1 30 0 159 $UPC 

T 7 0 0 230 $$PRICE 

FORM 

PRINT 
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Please consult your mobile printer‟s documentation for specific print commands. 

Note that Retail Mobile Suite will make the following substitutions automatically: 

Variable Value 

$DESC1 Desc1 

$DESC2 Desc2 

$ITEM_NO Item No. 

$UPC UPC 

$ALU ALU 

$SIZE Size 

$ATTRIB Attrib 

$PRICE Price 

$PWT Price with tax 

$QTY Quantity 

5.4 Managing Print Templates 
You can add, get, or remove printer label templates from your mobile device by 
connecting your mobile device to your workstation and selecting the Print 
Templates… menu item: 

 

The following screen displays the currently loaded print templates on your 
device: 
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Add 

Clicking the Add button brings up a standard file chooser with which you can 
select templates on your workstation for use on your mobile device. 

Get 

Clicking the Get button allows you to retrieve print templates on the device.  A 
standard Save As… dialog allows you to store the print template anywhere you 
want locally. 

Remove 

Click Remove to permanently remove a print template from the device. 

Refresh 

Click Refresh to refresh the display of templates on the mobile device. 

6 Uninstalling Retail Mobile Suite 

6.1 Uninstall Workstation 
To uninstall Retail Mobile Suite from a workstation: 

1. On the workstation, go to Start Menu > Settings > Control Panel > Add 
or Remove Programs. 

8. Find Retail Mobile Suite and Retail Mobile Services in the list and click 
Remove. 

6.2 Uninstall Mobile Device 
To uninstall Retail Mobile Suite from a mobile device: 
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1. On the mobile device, go to Start Menu > Settings > System > Remove 
Programs. 

2. Select the entry FoundryLogic Retail Mobile Suite and click Remove. 

7 Troubleshooting 
Issue Solutions 

Windows does not 
recognize my device or 
ActiveSync does not 
connect my device. 

1. Check your mobile device‟s USB cable 
connection to your workstation. 

2. Check that the mobile device is fully seated in 
its cradle, and power off/on the device. 

3. Perform a „warm boot‟ on your mobile device. 

The Scan Sessions 
window does not appear 
when the Barcode 
button, Upload Items 
button, or Portable 
Terminal tab is clicked in 
Retail Pro. 

1. Check that the Scan Sessions window isn‟t 
just minimized or behind another window. 

2. Verify that ActiveSync is running and shows 
your device is connected to the correct 
workstation. 

3. Verify that the Retail Mobile Suite workstation 
component is running. 

4. Verify that the Retail Mobile Suite workstation 
component is configured for the correct Retail 
Pro workstation number. 

5. Verify that the Retail Mobile Suite workstation 
component is configured with the correct 
Retail Pro installation directory.  In V8, this 
directory contains RPro8.exe.  In V9, this 
directory contains RPro9.exe. 

6. (Retail Pro V8)  Verify that Workstation 
Preferences > Peripherals > Barcode 
Reader > Barcode Reader Type is set to 
Palm.  You may need to restart PI Tool for this 
change to take effect. 

7. (Retail Pro V9) Verify that Workstation 
Preferences > Peripherals > Inventory 
Scanner is set to Palm SPT1800 v.1.0.0. 

The Scan Session 
window appears, but 
does not display my 
session. 

 

1. Press the Refresh button. 

2. Verify that your session has successfully been 
sent from the mobile device and shows a 
Green status. 

3. For Retail Mobile Services:  verify that Retail 
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Mobile Services is running on a network 
workstation, and that the Desktop and Mobile 
software options have both been configured to 
send & receive sessions to the correct 
Hostname, Port, and Channel. 

4. For ActiveSync:  verify that ActiveSync is 
running and shows your device is connected 
to the correct workstation. 

My mobile device is 
running out of memory. 

1. Remove unnecessary applications and data 
from your mobile device. 

2. Reduce the number of historical sessions 
stored on the device. 

3. Manually purge large session files when they 
are no longer needed. 

4. Reduce the generated inventory file size by 
turning off unnecessary data. 

My mobile device runs 
out of memory when 
uploading a new 
inventory file. 

1. Please see the steps regarding My mobile 
device is running out of memory. 

2. On the device, go to Device Configuration > 
Inventory and select Clear Inventory, then 
reconnect the device to reload the inventory 
file. 

The barcode scanner 
isn‟t working at all. 

1. Check that your mobile device‟s scanner 
configuration is enabled and configured 
correctly for the types of barcodes and 
surfaces that you are trying to scan.  Note that 
some scanners have very different 
performance characteristics with regard to 
barcode types and surfaces. 

The first barcode is 
scanned correctly, but 
the second is entered 
into the qty field. 

1. Go to http://foundrylogic.com and verify that 
you have configured the scanner for your 
specific device. 

2. Go to Device Configuration > Wedge on 
your mobile device and follow the on-screen 
directions to configure Retail Mobile Suite.  Be 
sure that you test scanning with each scan 
button on your device.  

Scanned barcodes are 
read, but not correctly. 

1. Check that your mobile device‟s scanner 
configuration is configured correctly with 
regard to prefixes and suffixes, and that the 
ENTER key is sent with the barcode data. 

http://foundrylogic.com/
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2. Go to Device Configuration > Wedge on 
your mobile device and follow the on-screen 
directions to configure Retail Mobile Suite.  Be 
sure that you test scanning with each scan 
button on your device.  

3. Check that the Device Configuration > 
Inventory > Item Lookup Order is the correct 
order. 

Retail Mobile Suite tells 
me that a scanned item 
was not found. 

1. Verify that your scanner is working correctly. 

2. Check that the item is actually in your Retail 
Pro inventory. 

3. Regenerate the inventory file and be sure that 
the item was not excluded. 

4. Verify the inventory file was generated with the 
minimum size lengths used on labels. 

5. If scanning UPCs and/or ALUs, be sure that 
UPCs and/or ALUs are included in the 
inventory file. 

6. If the label uses a vendor‟s UPC or ALU, be 
sure that vendor UPCs and/or ALUs are 
enabled when generating the inventory file.  

Retail Mobile Suite found 
the item I scanned, but 
field XXX is not shown. 

1. Check that field XXX is included in the 
inventory file when generated. 

2. Check that the item actually has data in field 
XXX in Retail Pro. 

When importing items for 
PI in V9, Retail Pro does 
not recognize the items 
and places valid 
identifiers in the Import Id 
column of the Errors 
screen. 

1.  (Retail Pro V9) Check that System 
Preferences > Local Preferences > 
Documents > General Item Lookup By 
includes UPC, ALU, and/or Item # as required 
to identify your items. 

2. Be sure the identifiers are valid and not 
duplicated. 

Not all of my items are 
generated in the 
inventory file. 

1. Verify the DCS codes are included in the 
Generate Inventory File form. 

2. (RPro V8) Verify the missing items have a 
DCS code. 

 


